You are not logged in.

Dear visitor, welcome to Fortuner 4x4 Fans. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Sujith Ramphal" started this thread

Posts: 1

Date of registration: Jun 10th 2017

Location: Midrand

Occupation: Regional operations manager

Car: Toyota Fortuner

Level: 5 [?]

Experience: 101

Next Level: 173

  • Send private message

1

Sunday, June 11th 2017, 8:48am

Limp mode

Hi everybody. My name is Sujith. I have 2007, Toyota Fortune 3 D4D. The problem I have is that, when my Fortune reach 3500 RPM or 140 KPH on the 5th gear only it goes into limp mode. Then I pull over. Switch the engine off, pull the key out and re insert it in the ignition and and re start the vehicle again and the problem is gone.

Sent from my Hisense C30 using Tapatalk

Garreth G

Professional

Posts: 686

Date of registration: Oct 5th 2015

Location: West-Rand

Car: Toyota Fortuner 3.0 D-4D Isuzu KB320 Frontier

Level: 33 [?]

Experience: 490,919

Next Level: 555,345

  • Send private message

2

Sunday, June 11th 2017, 11:31am

Quoted

Hi everybody. My name is Sujith. I have 2007, Toyota Fortune 3 D4D. The problem I have is that, when my Fortune reach 3500 RPM or 140 KPH on the 5th gear only it goes into limp mode. Then I pull over. Switch the engine off, pull the key out and re insert it in the ignition and and re start the vehicle again and the problem is gone.

Sent from my Hisense C30 using Tapatalk


Best thing is when it happens take it to toyota to run a diagnosis test on it.

That will help you a lot and save some money. It will give you a good idea where to look.


Sent from my iPhone using Tapatalk

Zion

Beginner

Posts: 40

Date of registration: Apr 29th 2013

Location: Cowies Hill, Durban

Occupation: Draftsman

Car: 2006 Toyota Fortuner D4D 4x4

Level: 24 [?]

Experience: 64,166

Next Level: 79,247

  • Send private message

3

Tuesday, June 13th 2017, 8:19am

Hi Sujith,

I have a 2006 model. I had the vehicle go into LIMP mode on a trip back from the North Coast once too. Took it for diagnostics and the issue was a dirty Mass Airflow Sensor(MAF). Had it cleaned with a special cleaner and have been trouble free since.

Best bet would be diagnostics to pinpoint the issue before starting to throw money at "possible" problems.
_____________
Dijon
_____________________________________________________________________________
"A truly rich man is one whose children run into his arms, even when his hands are empty."

AJ Venter

Trainee

Posts: 71

Date of registration: Apr 29th 2015

Location: Swakopmund

Car: Fortuner D4D 4x4

Level: 23 [?]

Experience: 62,053

Next Level: 62,494

  • Send private message

4

Tuesday, June 13th 2017, 9:22am

Hi
I did get limp mode once , but I was Full speed for about 200km and the weather was very hot. Also just stopped, switched ignition off & on and was sorted.

AmadaXtreme

Commercial Member

Posts: 1,185

Date of registration: Jul 25th 2013

Location: Centurion

Car: Fortuner d4d 4x4

Level: 40 [?]

Experience: 1,797,825

Next Level: 2,111,327

  • Send private message

5

Tuesday, June 13th 2017, 4:24pm

My Fortuner only goes in limp mode at the coast... but every time I get back all is ok... so has never checked it... think its time to check the fault codes.. gut feel says it might be the air mass
AmadaXtreme Suspensions
Diamond Park nr2, 86 Jakaranda Str, Hennopspark, Centurion
S25°51'50.2 E28°09'58.2

Cobus 071 641 7947 cobus@amadaxtreme.co.za

Rooster

Trainee

Posts: 80

Date of registration: Jul 29th 2016

Location: Pretoria

Car: Fortuner V6 4L Auto

Level: 21 [?]

Experience: 33,363

Next Level: 38,246

  • Send private message

6

Thursday, June 15th 2017, 2:18pm

....have it tested....BOSH will ask only a few bucks to diagnose the problem - but you can buy a good quality electrical cleaner and clean some sensors and connections yourself....mass airflow, air cleaner, diesel filter, EGR ect. there are just too many things and on the diesels there could be injector issues ect.

Obviously she is unhappy about something and before you ruin the relationship it would be best to find the root cause of her unhappiness and address it....haha now I sound like a relationship consultant.... :D

Similar threads

Rate this thread