You are not logged in.

Dear visitor, welcome to Fortuner 4x4 Fans. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Michaelleroux16" started this thread

Posts: 1

Date of registration: Dec 4th 2018

Location: Cape Town

Car: 2015 Toyota Fortuner D4D Epic

Level: 1 [?]

Experience: 6

Next Level: 10

  • Send private message

1

Tuesday, December 4th 2018, 10:37am

New member

Hi guys,

Thank you for the opportunity to be part of your group! I am excited to learn what I can from all you experienced Fortuner fanatics!

I bought my first Fortuner a few months ago, it is a 2015 D4D Epic 4x4 model. I have had a great time with it, as a new 4x4’er, it was pretty awesome to learn in such a highly capable vehicle!

I have an issue that I hope some of you could help... I have an issue with my factory battery. It has up and failed on me while running pretty normal. We were out at a restaurant last night and when we got to the Fortuner to get going, it showed me the proverbial middle finger! Luckily I had some leads.

Put it on a tricle charger when I got home and checked it again this morning... sorry to say but she has passed...

Now I have to bed the question; why did it happen? Was it because of Unichip sortware I had installed a week ago? Was it just luck of the draw or is there something more sinister at work?

Finally, what would you recommend as a suitable and reliable replacement battery. Last time my wife went to Battery Centre in N1 City, they sold her a R5k battery (and said it had to be that battery!) for my Ford Ranger. I don’t want to support companies like that but I need a battery nonetheless.

Fortuner is stock standard other than the software. No fridges, second batteries, no camping done with it yet.

I do apologize for the lengthy introduction and moreover apologize if this was not the correct platform for the question. Please help me right if need be.

Thanks ladies and gentlemen, have a fantastic day further!

AJ Venter

Trainee

Posts: 164

Date of registration: Apr 29th 2015

Location: Swakopmund

Car: Fortuner D4D 4x4

Level: 29 [?]

Experience: 216,586

Next Level: 242,754

  • Send private message

2

Tuesday, December 4th 2018, 11:49am

Welcome Welcome Michael !!!!!! I think it was just the time for the battery to die. I would lie to you if I tell you which battery to buy. Luckily there are people on this forum that will give you the best answer.
:beer: :beer:

JPC

Intermediate

Posts: 186

Date of registration: Apr 18th 2016

Location: Cape Town

Car: Fortuner 3.0 D4-D4x4

Level: 28 [?]

Experience: 179,618

Next Level: 195,661

  • Send private message

3

Tuesday, December 4th 2018, 2:54pm

Hi guys,

Thank you for the opportunity to be part of your group! I am excited to learn what I can from all you experienced Fortuner fanatics!

I bought my first Fortuner a few months ago, it is a 2015 D4D Epic 4x4 model. I have had a great time with it, as a new 4x4’er, it was pretty awesome to learn in such a highly capable vehicle!

I have an issue that I hope some of you could help... I have an issue with my factory battery. It has up and failed on me while running pretty normal. We were out at a restaurant last night and when we got to the Fortuner to get going, it showed me the proverbial middle finger! Luckily I had some leads.

Put it on a tricle charger when I got home and checked it again this morning... sorry to say but she has passed...

Now I have to bed the question; why did it happen? Was it because of Unichip sortware I had installed a week ago? Was it just luck of the draw or is there something more sinister at work?

Finally, what would you recommend as a suitable and reliable replacement battery. Last time my wife went to Battery Centre in N1 City, they sold her a R5k battery (and said it had to be that battery!) for my Ford Ranger. I don’t want to support companies like that but I need a battery nonetheless.

Fortuner is stock standard other than the software. No fridges, second batteries, no camping done with it yet.

I do apologize for the lengthy introduction and moreover apologize if this was not the correct platform for the question. Please help me right if need be.

Thanks ladies and gentlemen, have a fantastic day further!
Welcome to the board Michael, awesome vehicle that you bought!! :beer:

the battery could've failed because of age, if you have a tacking device fitted, this could also cause the battery to go sooner than it should.

unfortunately i don't have advise on batteries, but R5k is ridiculous to pay for a battery.

good luck and enjoy your Fortuner,.

P.S. let us know what battery you fitted, price and where.......sharing is caring...... :popcorn:
His:
'14 Ford Ranger 2.2 Double Cab............ :whistling:
'09 Honda Varadero 1000

Hers:
'12 Fortuner 3.0 D4-D 4x4 MAN

Erik

Intermediate

Posts: 171

Date of registration: Jan 14th 2015

Location: Rustenburg, South Africa

Car: 2007 3.0 Fortuner

Level: 30 [?]

Experience: 243,826

Next Level: 300,073

  • Send private message

4

Wednesday, December 5th 2018, 8:55am

I fitted a normal Willards battery from Supa Quick. It came with a 25 month warrantee (which I did use on another battery once, and was replaced no questions asked) and I think I paid around R1800 for it.

The 25 month was the longest warrantee I could get from all the shops in Rustenburg.

Froll

Beginner

Posts: 11

Date of registration: Aug 26th 2018

Location: Vioolsdrif Northern Cape

Occupation: Farm Manager, maintenance

Car: 2010 4.0 L V6 4x4 Fortuner

Level: 10 [?]

Experience: 1,164

Next Level: 1,454

  • Send private message

5

Saturday, December 8th 2018, 8:26pm

Welcome Michael, when I got home last night from work I went to take the Fortuner out of the garage to go to town this morning. I only go to town once a month as we live 120 km from town. the battery was also half dead.I jump started it and left it till this morning. I had to jump start it again and drove to town with the battery still in, no problem. I replaced the battery with a willard 668, there was a sabat 668 in. I paid R1550 for the new battery at Tren tyres. I dont know how old the sabat was as I bought the Fortuner in March this year.We only use willard batteries on the farm and get good service out of them.

Similar threads

Rate this thread