You are not logged in.

ThamieD

Beginner

  • "ThamieD" started this thread

Posts: 3

Date of registration: May 15th 2018

Location: Johannesburg

Car: Toyota Fortuner V6 4.0 4x4 A/T

Level: 14 [?]

Experience: 4,033

Next Level: 5,517

  • Send private message

1

Friday, November 23rd 2018, 1:44pm

Loss of power on acceleration and steeps

Greetings Forumites,

I need advice on a persistent problem with my Tuna V6 A/T.

1. When the car is idle the rev count is fine but when I hit the acceleration pedal - I hear a "air release sound" before the car actually picks up the rev count.
2. When I try to accelerate on take off - the car goes into a limp mode and rev count drop. I will then have to take my foot off the pedal and allow it to gain momentum and slowly increase acceleration. This also happens when I overtake - in some instances it switches off.
3. On a steep, I cannot accelerate but have to keep the acceleration at at certain point. If the incline is too steep, then it fails to switch gears.

I have replaced most filters - as at first I thought it was the petrol filter.

I have also disconnected the airflow sensor and just blew with compressor - then put it back.

Could the problem be the gearbox since it also fails to change gears on an incline? What about the 'air release sound' when I hit on the accelerator when the car is on idle?

Bang_121

Unregistered

2

Monday, January 10th 2022, 7:21pm

Loss of power on acceleration and steeps

Hi ThamieD,

I am experiencing exactly the same with my Tuner 4.0 v6. Interesting to hear if you were able to get the issue diagnosed and fixed. Tx

Robk

Beginner

Posts: 9

Date of registration: Jan 4th 2018

Location: Pretoria

Car: Toyota Fortuner V6 2017

Level: 17 [?]

Experience: 13,277

Next Level: 13,278

  • Send private message

3

Tuesday, January 11th 2022, 5:11pm

I had a similar problem and it was attributed to a fuel pump failure. It was at it's worst when running low fuel levels or driving on a hot day.

Similar threads

Rate this thread