You are not logged in.

Tony Neo

Unregistered

1

Tuesday, July 30th 2019, 5:00am

High Oil Consumption

My 2005 Fortuner (2700cc Petrol) encounter high fuel consumption.

Normal 1L = 8.6km to 9km now 6Km to 7.7Km.

No sure what is the problem, please advise

Erik

Intermediate

Posts: 177

Date of registration: Jan 14th 2015

Location: Rustenburg, South Africa

Car: 2007 3.0 Fortuner

Level: 30 [?]

Experience: 297,148

Next Level: 300,073

  • Send private message

2

Tuesday, July 30th 2019, 11:45am

Why would you make the header Oil Consumption and then ask about petrol consumption?

Did anything change on the vehicle? Tires, mods, etc?

Breekbeen

Intermediate

Posts: 459

Date of registration: Jul 6th 2015

Location: Paarl

Occupation: Farm manager

Car: '10 Fortuner 3.0 d4d 4x4

Level: 35 [?]

Experience: 690,945

Next Level: 824,290

  • Send private message

3

Wednesday, July 31st 2019, 9:48am

That figures sounds about right for a 2.7.
????

Sent from my SM-G950F using Tapatalk
2010 3.0 D4D 4x4
OME, ARB bullbar, SNORKEL, T-Max Winch, African Outback Roof rack,
KC Hilights, Dastec Unichip

PJC

Intermediate

Posts: 261

Date of registration: Apr 2nd 2013

Location: Welkom

Car: 2007 Fortuner

Level: 34 [?]

Experience: 608,261

Next Level: 677,567

  • Send private message

4

Thursday, August 1st 2019, 7:33am

If this indeed is oil consumption ;( , yo really have a serious problem. If there isn't a big pool of oil under the car then check the turbo.

PJC

Intermediate

Posts: 261

Date of registration: Apr 2nd 2013

Location: Welkom

Car: 2007 Fortuner

Level: 34 [?]

Experience: 608,261

Next Level: 677,567

  • Send private message

5

Thursday, August 1st 2019, 7:35am

SORRY 2.7 No Turbo. My bad :rolleyes:

AmadaXtreme

Professional

Posts: 1,346

Date of registration: Jul 25th 2013

Location: Centurion

Car: Fortuner d4d 4x4

Level: 42 [?]

Experience: 2,983,717

Next Level: 3,025,107

  • Send private message

6

Thursday, August 1st 2019, 8:13am

If this indeed is oil consumption ;( , yo really have a serious problem. If there isn't a big pool of oil under the car then check the turbo.


Or check if the drain plug is in the sump....
AmadaXtreme Suspensions
203 Edison Crescent, Weca 4x4, Hennopspark, Centurion
S25°51'50.2 E28°09'58.2

Cobus 071 641 7947 cobus@amadaxtreme.co.za

Similar threads

Rate this thread